Tuesday, May 23, 2006

Ahh Adobe how you kill me...

I installed the CS2 patch last week... I quickly discovered that it broke half of my scripts. I spent several hours with Adobe's lovely script IDE, but it kept choking on basic things like "app.activeDocument" after banging my head for a while, I noticed that some other scripts that used the EXACT SAME CODE were running fine.
I searched the Scripting Forums for an answer, but got nothing.

I tested the IDE with the script that WAS working, and it choked at the same place. I immediately closed the IDE and went back to using editPlus.

I discovered that the © copyright symbol (inside a COMMENT TAG!!!) was killing my scripts. I quickly fixed all scripts and uploaded the changes... OK, problem solved with minimal pain...

But the story does not end there. I went to Adobe's Studio Exchange and noticed that my "vary hues" got a 1 star rating from someone who experienced the same problem. I cannot comment on the post, I cannot delete the post, I can only "report abuse" but that doesn't give me a chance to explain to Adobe why I'm reporting the "abuse".

I went to Adobe's support page and filled out a form stating that I was having a problem with the exchange's user interface. The form stated in bold at the bottom that Adobe would get back to me in a day or two.

This is a copy of my letter:

Usability of the "Adobe Studio Exchange" for Contributors.

I'd like to request that you improve the management of the comments/rating system. I posted "Vary Hues" and it got a 5 star rating from the first user, then due to an inconsistency in the way text is handled by the CS2 upgrade, the script stopped working and another user rated it a 1 star. I've fixed the problem, but now I have a 3 star rating, and no way to inform users that the bug was there, or was fixed.

My only option for addressing it seems to be the "report abuse" button, but then I am unable to explain what the problem is.

I enjoy developing scripts for Illustrator, but posting them on the exchange is becoming a frustrating process for me.
Please send me some sort of feedback so I know Adobe is listening.

5 minutes after submitting the form I got a CGI response that reads:

We're very sorry, but Adobe is unable to provide answers to technical support questions via e-mail. However, extensive complimentary online resources are available at


Oh the irony.. :)
Good news, the person who gave my script a bad review updated his review, and my "vary hues" script now has the stars it deserves. :) Thanks man.

No comments: